Upgrading snap versions


#1

Hi. I have Wekan 0.60 via snap on Ubuntu 16.04 LTS. My question is how to deal with subsequent version upgrades. Do I just snap install wekan on top of existing and everything works fine, or is there something else that’s needed?


#2

HI, to install later versions. I did the following:

  1. Backup database: sudo wekan.database-backup
  2. Copy backup file: sudo cp /var/snap/wekan/common/db-backups/“filename”.backup /path/to/backup/
  3. uninstall wekan: sudo snap remove wekan
  4. install wekan: sudo snap install wekan
  5. set up wekan:
    5.1. sudo snap set wekan root-url="http://wekan.example.com"
    5.2. sudo snap set wekan port="80"
    5.3. sudo snap set wekan mail-url="smtp://wekan@example.com:pass@smtp.example.com:25"
    5.4. sudo snap set wekan mail-from=“wekanwekan@example.com
  6. back database again: sudo wekan.database-backup
  7. copy previous backup: sudo cp /path/to/backup/“filename”.backup /var/snap/wekan/common/db-backups/
  8. go to the folder: cd /var/snap/wekan/common/db-backups/
  9. restore backup: sudo wekan.database-restore “filename”.backup
  10. restart services:
    10.1 sudo systemctl restart snap.wekan.mongodb
    10.2 sudo systemctl restart snap.wekan.wekan

best regards
Carlos Aravena


#3

I tried this process but I seem to have received the same version 0.60 after I ran “sudo snap install wekan”. Is there something I need to do to get the update in snap, or does it just not exist yet?


#4

@xwhnenaz

Newer snap does not exist yet.


#5

I’m revisiting this as I’ve noted my Wekan installation seems to have automatically updated itself without me having to do anything! Version number now reported as 0.75. I don’t understand snap much yet but is this expected? I also seem to lose my SMTP server variables daily being replaced with mailserver.examples.com and I have to log in and just click ‘save’ and the SMTP settings that show are then applied.


#6

Yes snap upgrades automatically, it’s the main benefit of using snaps, for servers, IoT etc.

Yes it looses root-url settings etc, I’m waiting for bugfix https://github.com/wekan/wekan-snap/issues/29