Nginx reverse proxy Configurations


#1

Wekan installed and running as backend localhost:8080 as per installation manuals,
Nginx has been configured to act as reverse proxy on the same machine so that, requests to,
https://localhost:7443 to be proxied to Wekan backend.

Caddy server is on another central machine to handle requests to https://wekan.domain.com to access wekan.
access, login adding boards and cards are doing fine, but, when to get into card details, requests shows the below Non-TLS, backend URL’s
localhost:8080/b/vb76xvbsHe3yKHPW9/welcome-board/PpQoGhWY2NXCgsuS9

Proxy settings on Caddy is to proxy all, Please advise.


#2

@vClouds

At your Wekan server, you need to setup ROOT_URL to be your real wekan https url of caddy server.

In caddy config do proxy to your Wekan server IP address.

There are examples at Wekan GitHub wiki.