Install within Plesk


#1

Hi everyone,

I would really like to use Wekan but so far I have miserably failed to get it to run.

I have a vServer with Plesk running to administrate any websites/apps running on the server and I thought it would be easy to use the docker extension in Plesk to run Wekan.

However, after starting a mongodb container (according to logs listening on 27017) my wekan container always fails to connect to the database.

Since I’m not experienced in any of the underlying technology (I don’t even know how to verify that the database is accessable on the server) I’m very quickly at my wits end here.

What can I do for anyone here to be able to help me to set up Wekan on my server?

Thanks and cheers
goddib


#2

@goddib

Please add details how did you try to install Wekan, with what commands etc.


#3

Also include all error messages etc


#4

Hey goddib! Welcome to my world. Wekan is truly great for advanced techies, but I myself have been trying to install it (with Plesk as well as sole Ubuntu 16.04 server) and haven’t succeeded. Won’t say I have no idea whatsoever on how to do things, but no tutorial has helped me so far (trying for several months now, from time to time). I’m sure Wekan would be spread much more, if the installation process wouldn’t be so tricky. Great idea! Great programmers! But more for proficient users. I will keep trying to install it a bit more, until frustration factor will reach certain level… Please developers, consider the not so proficient user and your (great) software will reach much more people…


#5

installation using the snap package is pretty simple (and if you are on ubuntu 1604 available by default)

sudo snap install wekan

serves wekan on the ip address of your server using port 8080


#6

Thank you vrms for you reply. Tried that too.
First, snap isn’t installed by default on my vserver’s Ubuntu server version. Had to install snapd. And then:

  • Mount snap “core” (2898) ([start snap-core-2898.mount] failed with exit status 1: Job for snap-core-2898.mount failed. See “systemctl status snap-core-2898.mount” and “journalctl -xe” for details.

As I said, tried it (almost) all already, but thank your very much for helping.
Klaus


#7

Unfortunately my server runs on Debian, so I’m not able to try Snap without installing everything from scratch.


#8

Hi @xet7 and thanks for getting back to me.

As mentioned before, I was trying to install Wekan through the Plesk Onyx admin web interface (https://www.plesk.com/). Plesk has a capability for extensions, one of which is a Docker frontend. Through that frontend I installed the wekanteam/wekan and mongo:3.2.14 container.

While the MongoDB container seems to run and listen on the expected port, the wekan container fails with the following error message:

/build/programs/server/node_modules/fibers/future.js:313
						throw(ex);
						^
MongoError: failed to connect to server [wekandb:27017] on first connect
at Object.Future.wait (/build/programs/server/node_modules/fibers/future.js:449:15)
at new MongoConnection (packages/mongo/mongo_driver.js:211:27)
at new MongoInternals.RemoteCollectionDriver (packages/mongo/remote_collection_driver.js:4:16)
at Object.<anonymous> (packages/mongo/remote_collection_driver.js:38:10)
at Object.defaultRemoteCollectionDriver (packages/underscore.js:784:19)
at new Mongo.Collection (packages/mongo/collection.js:99:40)
at packages/idmontie_migrations.js:38:15
at packages/idmontie_migrations.js:255:4
at packages/idmontie_migrations.js:267:3
at /build/programs/server/boot.js:303:34
- - - - -
at [object Object].<anonymous> (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb-core/lib/topologies/server.js:326:35)
at emitOne (events.js:77:13)
at [object Object].emit (events.js:169:7)
at [object Object].<anonymous> (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb-core/lib/connection/pool.js:270:12)
at [object Object].g (events.js:260:16)
at emitTwo (events.js:87:13)
at [object Object].emit (events.js:172:7)
at Socket.<anonymous> (/build/programs/server/npm/node_modules/meteor/npm-mongo/node_modules/mongodb-core/lib/connection/connection.js:175:49)
at Socket.g (events.js:260:16)
at emitOne (events.js:77:13)

As the nature of a web interface, I have not entered any commands on command line.

Thanks and cheers
goddib


#9

@goddib

Did you use Docker Compose?

What commands did you use to start Wekan?

How much free RAM there is for Wekan?


#10

No I did not use Docker Compose, even though I tried doing that on command-line, too. But since the webservers are administrated through Plesk I figured I should also use docker through the web interface.

Thus, I did not run any commands but simply clicked “start” in the web interface.

My machine has 8GB ram which are mostly available for Wekan since not much else is running on the machine.

Thanks and cheers
goddib