I get redirected to "localhost" when clicking on a card


#1

I have Wekan installed on Ubuntu Server 17.04, I also tried 16.04 with the same result.
I installed Wekan using Snap by running “sudo snap install wekan-ondra”, and thats it.

When I go to “192.168.1.237:8080”, i get greeted with a Wekan login screen, I try to register an account and it says “internal server error”, however it lets me login anyway, so I do.

Most of the features seem to work except when I try to click on a card, it redirects to “http://127.0.0.1/b/peJELJqrgJiXLcLuo/welcome-board/mHMMnkXaAPz8qDuum”, obviously this just causes my browser to give me a “This site can’t be reached” error.

Now if I change in the address bar, the “127.0.0.1” to “192.168.1.237:8080” and leave everything else the same then it shows the card page correctly like I would expect.

Im not sure what to do here, I have poked around the forums and haven’t come across anyone with the same issue.


#2

Hi There
This is a cut and paste of my solution -sent before- to this problem.

It may be well known for a lot of you guys but in case there is another person as I was, here it is my solution.
First the background:
Machine: Ubuntu 16.04
Mem: 12Gb
Problem: Redirected to ‘localhost’ or 127.0.0.1

Solution:
After Wekan has been installed (linux), type the following settings from the command line to solve the issue. Assuming you machine IP is 192.168.0.4 (you can find your IP with ipconfig)

cd ~/wekan/bundle
export MONGO_URL='mongodb://127.0.0.1:27017/wekan’
export ROOT_URL='http://192.168.0.4:3000
export MAIL_URL='smtp://email_addr@gmail.com:email_pwd_here@smtp.gmail.com:25/'
export PORT=3000
node main.js

These settings need to be re-issued every time you start WEKAN, unless you made them permanent. Hope this helps, I’m not an expert but this to solve the problem for me.

Cheers

Amaro


#3

ROOT_URL needs to be full url to real address where wekan is, for example https://example.com/wekan if there is Nginx or Caddy at front. Please see Wekan GitHub wiki for more info.


#4

for local and intranet use, ip address and port can be there.


#5

virtualbox images’s version 0.49 wekan, I solved change
/home/wekan/repos/run-wekan.sh ROOT_URL to my ip,then restart system,it’s ok then.


#6

That was it: I hadn’t added the local port when I specified the ROOT_URL. Now that I use http://xxx.xxx.xxx.xxx:xxxx format it’s working! Thanks!