Firefox can’t establish a connection to the server at 127.0.0.1


#1

Hi There,
I’m very new to Wekan so be patient. I have installed it using sudo snap install wekan-ondra
All works ok, however, I’m seeing the following problem:
After creating a few cards, when I try to click on any of them I’m getting this error.

Unable to connect
Firefox can’t establish a connection to the server at 127.0.0.1.

The link associated with each card is of the form
http://127.0.0.1/b/zcbJH4HXsZgszRNQR/problem-solve/JjTcNNKMr3x5qTsaH

I believe the link should be of the form:
http://machine-IP-address/b/zcbJH4HXsZgszRNQR/problem-sove/JjTcNNKMr3x5qTsaH

Could you please let me know what setting need to be changed, where to change it and how.

Just to provide more information my machine is:
Ubuntu 16.04
Mem 12Gb

Any help comments will be much apreciated

Regards,

Amaro


#2

Just to add more information to this issue.

I have installed the VM and though it works well. It also comeback with the same error as described above, meaning only the front page works well.

However, if I “Add a card” then, when I try to click on that new card, it only workls if I’m on the browser of the actual VM. But,

When I access WEKAN from host machine broser (instead of VM) everything works just fine for the main page (which is accessed by VM IP address). Howver, if I try to access (meaning click on) any Added card, it goes to localhost/link and gets the “Server not found” error.

Interestingly enough is the following:

On the page I get the error (meaning I’m on the Host server) I can manually replace the word localhost by insert the ipaddres (of the WEKAN machine) and all works ok for that page.

Similar behaviour for all other cards.

This lead me to think that localhost is a setting than need to be replaced with machine IPaddress. However, I don’t know where to do this.

Any help? Thoughts or ideas are more than welcome

Cheers

Amaro


#3

@amaro

GitHub issues are used for bugs and features, not forum. I think those you mentioned are at GitHub issues already, so some contributor or I can check them sometime. If not, add new issue.

If those platforms you mentioned don’t work at the moment, you could meanwhile try Sandstorm.


#4

Hi There
Thank you for your reply. I’ll try Sandstorm and see how I go. Nevertheless, If you do know the cause of it or if you can point me to where it has been discussed I’ll appreciate that.

Regards

Amaro


#5

@amaro

Up-to-date platforms, although they can have this bug. Sandstorm works.

Nginx webserver config

Nginx workaround

Caddy webserver config

Bug: Some modules not using ROOT_URL


#6

Hi There,
It may be well known for a lot of you guys but in case there is another person as I was, here it is my solution.
First the background:
Machine: Ubuntu 16.04
Mem: 12Gb
Problem: As described above

Solution:
After Wekan has been installed, issue the following settings from the command line to solve the issue described above. Assuming you machine IP is 192.168.0.4 (find yours with ipconfig)

cd ~/wekan/bundle
export MONGO_URL='mongodb://127.0.0.1:27017/wekan’
export ROOT_URL='http://192.168.0.4:3000
export MAIL_URL='smtp://email_addr@gmail.com:email_pwd@smtp.gmail.com:25/'
export PORT=3000
node main.js

These settings need to be re-issued every time you start WEKAN, unless you made them permanent.

Cheers

Amaro


#7

There are snap settings you can configure. If you don’t get it working, please add new issue to